WordPressやSymfonyのTipsを中心にアニメや日常の出来事について語ります。
メニュー

Moval Type6.0.3に「mt-tinymce-field 0.60」プラグインをインストールしたときの問題の対処法

この記事は約1分17秒で読めます

Movable-Type-0-Day-Vulnerability-Used-to-Hack-into-PBS-Patches-Available-2
ゆっきー
ども、カフェブロガーの悠木です。 お気に入りのカフェはドトールコーヒーです。 14時からの限定スイーツ「シューシャポー」が大好きです。

この記事は自分用の備忘録です。

Moval Type 6.0.3
mt-tinymce-field 0.60

導入までの流れ

「mt-tinymce-field」をダウンロード

mt-tinymce-fieldのGitHubから「mt-tinymce-field-master.zip」を解凍します。

「mt-tinymce-field」をインストール

ダウンロードしたzipファイル「mt-tinymce-field.zip」を解凍します。

mt-tinymce-field-master/plugins/TinyMCEField

このようなフォルダ構成になるので「TinyMCEField」をmtのプラグインフォルダに入れます。

/cgi-bin/mt/plugins

私の場合は上記のフォルダ内へ「TinyMCEField」を入れました。

「Failed to load YAML document from string」エラー発生

Got an error: Error reading /var/www/cgi-bin/mt/plugins/TinyMCEField/config.yaml: Failed to load YAML document from string

プラグインフォルダへ追加後、MTのプラグイン一覧を更新すると上記のエラーメッセージが表示されました。
ダウンロードされたファイルが間違っているだと・・・!?

「Failed to load YAML document from string」エラーの対処法

ググってみましたが、他の人は発生していないエラーのようです。
私の環境だけでしょうか?

試しに、config.yamlに空の改行を末尾に追加して保存して再度アップロードすると・・・

mt-tinymce-field

うまく「mt-tinymce-field」プラグインを読み込んでくれました。
yamlファイルでこういうエラーがでるととりあえず改行してみますよね。

PR

カテゴリー